← All CVEs

CVE-2026-59085

critical · 9.1

Server-Side Request Forgery (SSRF) vulnerability in Apache CloudStack's webhook module, exploitable via webhook delivery requests. This issue affects Apache CloudStack: from 4.20.0.0 through 4.20.3.0 and from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.20.3.1 or 4.22.1.1 or later, which fixes the issue.

9.1
CVSS
0.6%
EPSS (exploit prob.)
48th
EPSS percentile
2026-08-21
Published

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Weaknesses

CWE-918

Affected products

VendorProductAffected versions
apachecloudstack>= 4.20.0.0, < 4.20.3.1
apachecloudstack>= 4.21.0.0, < 4.22.1.1

Check a specific version with /api/v1/cve/match.

References

Query this programmatically:

curl https://evil-db.io/api/v1/cve/CVE-2026-59085