CVE-2026-62440
critical · 9.1Improper Access Control vulnerability in Apache CloudStack's Kubernetes Service (CKS) plugin, allowing cross-tenant manipulation of the Kubernetes cluster while adding and removing nodes. This issue affects Apache CloudStack: from 4.21.0.0 through 4.22.1.0. Users are recommended to upgrade to version 4.22.1.1 or later, which fixes the issue.
9.1
CVSS
0.5%
EPSS (exploit prob.)
45th
EPSS percentile
2026-08-21
Published
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-284
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| apache | cloudstack | >= 4.21.0.0, < 4.22.1.1 |
Check a specific version with /api/v1/cve/match.
References
Query this programmatically:
curl https://evil-db.io/api/v1/cve/CVE-2026-62440