CVE-2026-65182
critical · 9.1Improper Access Control, Incorrect Authorization vulnerability in Apache Tomcat leads to security constraint bypass if a constraint for a longer path is specified before a more restrictive constraint for a shorter sub-path. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Users are recommended to upgrade to version 11.0.25, 10.1.58, 9.0.121, which fixes the issue.
9.1
CVSS
0.5%
EPSS (exploit prob.)
45th
EPSS percentile
2026-08-25
Published
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-284CWE-863
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| apache | tomcat | >= 7.0.0, <= 7.0.109 |
| apache | tomcat | >= 8.5.0, < 9.0.121 |
| apache | tomcat | >= 10.1.0, < 10.1.58 |
| apache | tomcat | >= 11.0.0, < 11.0.25 |
Check a specific version with /api/v1/cve/match.
References
Query this programmatically:
curl https://evil-db.io/api/v1/cve/CVE-2026-65182