CVE-2026-65637
critical · 9.8Improper Input Validation vulnerability in Apache Tomcat due to incomplete fix for CVE-2026-32990. This issue affects Apache Tomcat: from 11.0.20 through 11.0.24, from 10.1.53 through 10.1.57, from 9.0.115 through 9.0.120. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fix the issue.
9.8
CVSS
0.6%
EPSS (exploit prob.)
49th
EPSS percentile
2026-08-25
Published
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| apache | tomcat | >= 9.0.115, < 9.0.121 |
| apache | tomcat | >= 10.1.53, < 10.1.58 |
| apache | tomcat | >= 11.0.20, < 11.0.25 |
Check a specific version with /api/v1/cve/match.
References
Query this programmatically:
curl https://evil-db.io/api/v1/cve/CVE-2026-65637