CVE-2026-67593
critical · 9.1A remote attacker can craft an Openwire RemoveSubscriptionInfo command to cause the deletion of a queue on the Artemis broker before the connection authentication and authorization stage or at any time thereafter. This issue affects Apache Artemis: from 2.50.0 through 2.56.0; Apache ActiveMQ Artemis: from 1.0.0 through 2.44.0. Users are recommended to upgrade to version 2.57.0, which fixes the issue.
9.1
CVSS
0.9%
EPSS (exploit prob.)
58th
EPSS percentile
2026-09-10
Published
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Weaknesses
CWE-306
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| apache | artemis | >= 1.0.0, < 2.44.0 |
| apache | artemis | >= 2.50.0, < 2.57.0 |
Check a specific version with /api/v1/cve/match.
References
Query this programmatically:
curl https://evil-db.io/api/v1/cve/CVE-2026-67593