← All CVEs

CVE-2026-68525

critical · 9.1

Incorrect Authorization vulnerability in Apache Tomcat's FORM authentication process allows the bypassing of a security constraint that limits user has access to a resource POST but not GET. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.24, from 10.1.0-M1 through 10.1.57, from 9.0.0.M1 through 9.0.120. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.25, 10.1.58 or 9.0.121, which fixes the issue.

9.1
CVSS
0.5%
EPSS (exploit prob.)
42nd
EPSS percentile
2026-08-25
Published

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Weaknesses

CWE-863

Affected products

VendorProductAffected versions
apachetomcat>= 7.0.0, <= 7.0.109
apachetomcat>= 8.5.0, < 9.0.121
apachetomcat>= 10.1.0, < 10.1.58
apachetomcat>= 11.0.0, < 11.0.25

Check a specific version with /api/v1/cve/match.

References

Query this programmatically:

curl https://evil-db.io/api/v1/cve/CVE-2026-68525