CVE-2026-71253
critical · 9.8Use of Externally-Controlled Input to Select Classes or Code ('Unsafe Reflection') vulnerability in Apache Johnzon. ClassConverter loads & static-initializes an attacker-named class from untrusted JSON. This issue affects Apache Johnzon: from 1.0.0 before 2.2.0. Users are recommended to upgrade to version 1.3.1 (javax namespace) or 2.2.0 (jakarta specification namespace), which fixes the issue.
9.8
CVSS
0.4%
EPSS (exploit prob.)
32nd
EPSS percentile
2026-10-19
Published
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-470
References
Query this programmatically:
curl https://evil-db.io/api/v1/cve/CVE-2026-71253