CVE-2026-71575
critical · 9.1The max_age authentication-freshness check in OidcClientCodeRequestFilter was inoperative due to a milliseconds/seconds unit mismatch and an inverted comparison polarity. Any relying party using setMaxAgeOffset to enforce re-authentication would silently accept sessions of any age, bypassing step-up authentication policies. Users are recommended to upgrade to versions 4.2.4 or 4.1.9 or 3.6.13, which fix this issue.
9.1
CVSS
0.4%
EPSS (exploit prob.)
29th
EPSS percentile
2026-10-09
Published
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-613
Affected products
| Vendor | Product | Affected versions |
|---|---|---|
| apache | cxf | < 3.6.13 |
| apache | cxf | >= 4.0.0, < 4.1.9 |
| apache | cxf | >= 4.2.0, < 4.2.4 |
Check a specific version with /api/v1/cve/match.
References
Query this programmatically:
curl https://evil-db.io/api/v1/cve/CVE-2026-71575